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WELCOME 
 
League Planner (LP) is a Windows based application written by a software development company 
“Visual Reality” and provided to the Lawn Tennis Association to aid League Organisers across 
Great Britain.  
 
We hope this user guide will provide guidance to new league organisers and refresh existing 
organisers in setting up and managing their leagues. The Competition Support Team has 
highlighted tips and important information throughout the guide, and we hope you find it useful. 
 

Using this Guide 

 
Those parts in of this user guide in red are mandatory to complete whereas the parts in black are 
optional. 
 
Important parts of the guide are highlighted in red boxes: 
 

IMPORTANT:   

 
Whilst tips are highlight in blue boxes: 
 

TIP:   

 
 

Further Support 

 
Further support is available from the regional Competition Development Partners and from the 
Competition Support Team at competitionsupport@lta.org.uk.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

mailto:competitionsupport@lta.org.uk
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GETTING STARTED 
 
 

Obtaining your League Planner Licence 

 

In order to use League Planner you will need a League Planner licence and have the up to date 

version of League Planner installed on your computer. Both expire annually and licences are 

renewed in January each year although you can apply for one at any time. To be eligible for a 

League Planner licence you must: 
 

• Be a Licensed Official, LTA Accredited Coach, Competition Organiser or Recognised Club 

Official. 

• Complete the Data Protection Agreement Form. Please note you only need complete this 

once. 
 
Having met these two requirements, you can apply for a League Planner licence by going onto the 
LTA website www.LTA.org.uk/LeaguePlanner and by selecting the link to Apply for a LP licence.  
 

Licences are processed within 5 working days provided the requirements are met. Your licence will 

be sent by email as an attachment. When it arrives, save it to your computer but do not open it. 
 
 

Installing League Planner 

 

Once you have been emailed your League Planner licence click on the link within the message to 

download the software.  
 

Alternatively log onto the LTA website www.LTA.org.uk/LeaguePlanner and select the Download 

LP link. 
 

Further information on how to install the software can be found here. 

 

 

 
 

Registering your Licence with League Planner 

 

TIP:  A step by step video is available to support users update their League Planner 

licence. This video is available online at www.LTA.org.uk/LeaguePlanner in the League 

Organiser Resources section.  

 
 
 
 
 

http://www.lta.org.uk/leagueplanner
http://www.lta.org.uk/leagueplanner
http://www.lta.org.uk/NewWebsite/LTA/Documents/Organisers%20and%20Officials/League%20Planner/TTPandLP_installation%20guidance.pdf
http://www.lta.org.uk/LeaguePlanner
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To register your license: 
 

1. Open League Planner on your computer. 
 

2. If you have had League Planner in previous years an error screen will appear showing the 

licence is not compatible with this version of League Planner. Click OK. 
 

 
 

3. If this is the first time you are installing League Planner or, you have clicked OK to 

acknowledge the error message, the registration screen will appear. Click Register 

 

 
 

4. Locate the licence file, select it and click Open 
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5. League Planner will confirm you have successfully registered your licence. Click OK to 

proceed to League Planner. 

 

 
 

Alternatively, a new / existing license can be registered through the Help tab. 

 

 
 
 

Applying for your League 

 

In order to have your league set up on the LTA database you will need to complete the League 

Application Form which is available on the League Planner page of the LTA website: 

www.LTA.org.uk/LeaguePlanner.  
 

Please complete the information required and, once finished, click the submit button at the bottom 

of the form. 

 

Your league application will be processed within 10 working days by the LTA Customer Support 

Team 
  

http://www.lta.org.uk/leagueplanner
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CREATING YOUR NEW LEAGUE 
 
The league creation section is critical to the success of your league. Please ensure you follow the 
steps in this section to ensure the leagues success.  
 

TIP:  A short video is available to support league organisers in setting up their league and 

 configuring the league properties in League Planner. This video is available online at 

 www.LTA.org.uk/LeaguePlanner in the League Organiser section.  

 

Creating a New League  

 
In order to create a new league follow the steps outlined below: 
 

1. Open League Planner and select the New option 
 

 
 

2. Enter a desired name and click Save in the pop up 
3. The new League will be created, and the League Properties pop up window will appear 

 

 
 

 

http://www.lta.org.uk/LeaguePlanner
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CONFIGURE THE LEAGUE PROPERTIES 
 

The key information about your league is held in the League Properties. You can access it by 

clicking on the League Properties button in the main toolbar or selecting the Properties option in 

under League. 

 

 
 

 
 

The more information you enter in League Properties the more efficiently your league will run.  
 

Enter all of the appropriate information required for your competition, reviewing each of the tabs in 

the league properties.   

 

TIP:  A short video is available to support league organisers in setting up their league and 

 configuring the league properties in League Planner. This video is available online at 

 www.LTA.org.uk/LeaguePlanner in the League Organiser section. 

 

 

 

 

 

 

 

 

 

 

 

http://www.lta.org.uk/LeaguePlanner
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Info 

• League Name - enter name of the league 

• League Number - this is the league code 

allocated by the LTA; it will contain an 

abbreviated county prefix. 

• League Organiser, Phone and Email - 

enter organiser details  

NB. When you publish, this is the name 

that will be displayed on the website. 

• Referee - the name of the referee 

• Logo - use the browse button to add a 

logo (e.g. sponsor).  
 
 

Address 

 

If you run a central venue league enter the 

address. Any detail you add in this section will 

appear on the website when you publish your 

league. 

 

NB. City and Country are mandatory as they 

provide a Google map when the league is 

published to show the location of your league 

venue/s.  

 

Events 

 

• League Type – fill in the relevant League 

Type information by clicking on Add next to 

the League Type box e.g Mens Singles 

 

 

 

• Events – add all Events that are running within the league by choosing the Add option next 

to the Event box. 

o Fill in the Event Name 

o League Type 

o Scoring Format (if different from the Standard scoring) 

o Entry fee (if the league is taking online entries) 
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• Stages – no amendments are needed here unless a Play Off or Pre-Qualifying Stage etc 

need to be added 

• Rubbers – Add in the number of rubbers the Event 

consist of. In the below example the Mens 40+ event has 

4 singles rubbers. 
 
MS   Male singles 
WS   Female singles 
MD   Male Doubles 
WD   Female Doubles 
XD   Mixed Doubles  
S (M/W)  Mixed Singles  
D (M/W) Mixed Doubles 
BS   Boys Singles 
GS   Girls Singles 
BD   Boys Doubles 
GD  Girls Doubles 

 

• Click Settings to ensure Gender and Type are correct. 

Fill the Min and Max Age based on the Event. In our 

example for a 40+ event the minimum age is 40 and the 

maximum age is 99. 
 

• Click Apply then OK 
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Days 

 

To add a day, click the arrows to change the 

month and year, then select the day from the 

calendar. Click Add to save your choice.   
 
To delete a day, select the day in the right hand 
part of the screen under Date and click Delete. 
Days can only be deleted if there are no 
matches scheduled for that day.  
 

Times 

 
Select the number of playing times per day 
using the up and down arrows in Times per day 
 
Use the Create functions to enter times and 
intervals for your tournament. The 1 day option 
allows you to create the times and intervals for 
individual days and the All Days option will set 
the times and intervals for every day of the 
league.  
 
You can increase the Times per day and add 
additional time slots at any time. NB you need to specify a location (see next section) or specify 
unlimited courts if you wish the times set to be recorded in your file.  If you fail to do this the times 
will disappear on closing the file.  
 
 

Locations/Courts 

 
If you don’t want to use all the scheduling 
features of League Planner (i.e. notifications of 
when you have run out of courts at a club) then 
you don’t need to add all your locations and 
courts. Instead edit the Main location by 
highlighting it and clicking Edit. Then click the 
Available Courts tab and select Unlimited 
courts. This will allow you to schedule your 
league without restrictions, however you will not 
be notified of court clashes.    
 
 
Follow these instructions to add locations and courts to use the full functions in this area. 
 

1. Use the Add button on the right hand side of the screen to add new locations. NB. A default 

location will always be present 
 

2. Enter the name of your location e.g. The National Tennis Centre 
 

3. Add courts to your location by clicking the Add button in the Location properties. Enter the 

court name or number and click OK. Repeat this process until you have added all the 

required courts. 
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4. Back on the Location properties screen add an address to the location (optional) 
 

5. Click on the Available Courts tab to either:  
 

• Specify available courts manually; calculate from availability per court, or use 

unlimited courts 
 

• Specifying available courts manually allows you to enter the number of courts that 

are available per day at this particular location. Each cell represents one time slot 

which you allocated in the Times tab. You can use the This Day button to copy a 

number of courts across all time slots on one day and the All Days button to copy a 

number of courts across all time slots on all days. NB. Available courts = the 

number of courts you have added to the location you are working in. 
 

• Calculate from availability per court means that the programme will analyse how 

many courts you have at each venue when you are scheduling and will stop you  

scheduling matches when no courts are available.  
 

• If you select Unlimited Courts you will be able to schedule without League Planner 

checking the court availability at all. 
 

 

Team Points 

 

This section details how the league table is 

to be calculated so you will need to have a 

clear understanding of your league rules. 

 

 
 
Please Note:   
 
A Match is defined as Team V Team (e.g. 
Putney V Roehampton) 
                      
A Rubber is defined as Player V Player (e.g. Nadal V Murray) 
 

The ‘scoring’ drop down list provides you with 6 options of different team points scoring options. 

 
LTA League Rules determines final positions based on the number of matches won, followed by 

number of rubbers won, head to head, percentage of sets won and finally percentage of games 

won. LTA league rules award 2 match points for a win and 1 for a draw. It completes the above 

standings calculation for you and is the recommended format. 

 

Points per Match and Sum of Points allow you to dictate the way in which the final standings in 

your league will be determined.  
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Points per Match – As it says, this option awards points per match. The ‘Points’ column in the 

standings calculation will show only the points awarded for winning the match. The ‘Matches’ 

column will record the number of matches won and lost. Bonus points can still be awarded (and will 

appear in the ‘Matches’ column). 

 

 
 

Sum of Points – this option does not award points for winning the match but adds up the rubber 

points awarded for winning or drawing rubbers.  

 

E.g. if your league awards 4 points for winning a rubber and 2 for a draw and a team wins 2 

rubbers and draws 2 rubbers the ‘sum of points’ option would award 12 points to the winner and 4 

to the loser.  

 

In your Standings table the total points won will appear in the ‘Points’ column and the match result 

(i.e. points won/lost) will appear in the ‘Matches’ column. 
 
 

 
 
 
 

 
You can add bonus points for winning/drawing/losing the match by using the bonus points section. 
 

 
 

These points will be added to the team score in the Points column but not to the Matches column. 

 

By using Points per Match and Sum of Points you will need to dictate your select criteria for 

determining the final positions in your league in the Standing Calculations area of Team Points.  
 

 
 

To determine your standings: 

1. Select the rules you wish to use 

2. Order the rules you have chosen by highlighting them and using the Move Up or Move 

Down buttons to create your priority order.   
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When you have finished your selected options should all be at the top of the list in the order in 

which you want them to apply.  Click Apply. 
 
Standing Calculations Definitions: 
 

Standing Definition 

Match Points total number of points awarded to each team for winning/drawing a match 

across the season 

Team Matches 

Won 

number of wins for each team (1 point issued per win). NB This could be 

the same as match points but will not be if your league permits draws. 

Rubber Points total number of points awarded for rubbers won by a team’s players (linked 

to player points) 

Rubbers Won total number of rubber wins for each team (1 point issued per win). NB this 

is not always the same as percentage of rubbers won/lost as it does not 

allow for matches to be unfinished (i.e. some teams may have played 

fewer rubbers than others - there is no option to deal with this situation). 

 

Set percentage compares the number of sets won and lost. 

Game 

percentage 

compares the number of games won and lost. 

Do not use 

results of retired 

players 

nullifies all results recorded against a player who has retired from the 

league, round robin etc 

Head to Head looks at the result between two teams to split teams who are tied in the 

league table 

The following options are unlikely to be of use – 
 

Standing Definition 

Sets Difference the difference between sets won and lost. This does not always produce 

the same result as set percentage.  For example, Team A plays 48 sets 

and wins 33, the set difference is 15, the set percentage is  68.75%, team 

B plays 54 sets and wins 39, the set difference is also 15 but the set 

percentage is 72.22%. 

Games 

Difference 

the difference between games won and games lost 

Games for the total number of games won by a team across all fixtures 

Sets for the total number of sets won by a team across all fixtures 

‘Relative options’ the theory is the same as per the descriptions above however it only 

compares the teams who are tied 

 
Please Note: To make Bonus Points effective you need to select Rubber Points in the standings 
calculations.  
 
Bonus Points Matches 
To add bonus points to the Point Column in your final standings select the number of points you 
wish to add for winning, drawing or losing.  
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Bonus Points Rubbers 
 
To add bonus point to rubber go to bonus points rubbers and select the number of rubber points 
you wish to add for winning, drawing or losing.  
 

 
 
If your league is not using online results and you wish to change your settings you can do so at any 
stage and amendments will be applied across your leagues, to both recorded and future results. If 
your league is using online results it is still possible to make changes but you will need to refer to 
the online league management manual to find out how to do this.  
 
Shootout 
 
To add a tiebreak shootout when the rubbers score is tied tick ‘Enable Shootout’. Adjust the 
Winner Bonus points value to the number of extra points you will award.  

 

 
 

Player Points 

 

Player points are the points awarded for each 

rubber (Player A (Nadal) V Player B (Murray)) 

played.  
 

Click on the Scoring drop down list and select 

one of the 3 options from the drop-down list. 
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Player Points Definitions 
 

Standing Definition 

Points Per 

Rubber 

allows you to choose the number of points to issue teams for a rubber win, 

loss or draw 

Points Per Set allows you to issue points for each set won, lost or drawn 

Points Per Game adds the games won by all the players in each team (used for mini tennis) 

 

Allocate the number of points that will be awarded for each rubber dependant on the result. 

 

  
 

Click Apply 
 
 
 

Draws 

 
The draws tab provides a number of 
options to help set up your draws. Tick 
the box to select the draw options you 
require  
 
Click Apply  
 
 

 

 

TIP:  It is advisable to select Balance home and away in round robins to balance the 

 fixtures and Show round numbers in round robins 

 
 
  



 

 

18 

Score 

 

You can set score settings per event 

which enables you to have multiple 

events with different scoring formats.  
 

To create a scoring format per event, 

click on the Add button nearest to Event 

Scoring and the following box will 

appear. 

 

In the title text field put the name of the 

event and then, for each match, select 

the relevant scoring format from the drop down menu.  Once you are finished click OK. 
 

IMPORTANT:   You will then need to link the scoring format to the event in the ‘Event 

   tab’. Select the Event to which you want to allocate the scoring  

   format. Click Edit and select the scoring format from the drop down list 

   in the Event Scoring field. Click OK. 

 

 

 
 

Officials 

 
Click Add and complete the required details. 
 

Entry Fees  
 
Add any additional Fees  
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ACCEPTING AND PROCESSING ENTRIES 
 

League Planner offers an export and import facility to efficiently enter data into your league. It is 

possible to export the clubs, teams and players from your previous season’s league, make 

amendments to the data in spreadsheet form and then import this into your new league. Likewise 

for new leagues it is possible to enter the data directly into a spreadsheet and import it into League 

Planner.  
 

TIP:  A step by step video to help League Organisers with importing their clubs, teams and 

 players into League Planner. Template spreadsheets which facilitate the importing 

 process are also available. Both these resources are available online at  

 www.LTA.org.uk/LeaguePlanner. 

 
 

Exporting From your Previous Season’s League 

 

Export Clubs 

 

To export your clubs click Player → Export Clubs and save the spreadsheet to your computer.  

 

 
 

You can then add, edit or delete clubs ready to import into your new league. Please note the Club 

ID field should be the club’s LTA registration number.  
 

Your clubs spreadsheet should look like this: 

 

 
 

 

http://www.lta.org.uk/LeaguePlanner
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Export Teams 

 

To export your teams click Team → Export Teams and save the spreadsheet to your computer. 

 

 
 

You can then add, edit or delete teams ready to import into your new league. Please note that if a 

club has two teams in one division these should be entered on separate lines and have separate 

Team IDs. You can add a suffix to the LTA registration number, say SUR099B12, for the 12U 

Boys’ team. This gives each team a unique identity. 
 

Your teams’ spreadsheet should look like this: 
 

 
 
 

Export Players (optional) 

 
If the previous league hasn’t been managed online and players have been entered into the League 
Planner file you can export your players by clicking Player → Export Players and save the 
spreadsheet to your computer. 
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You can then add, edit or delete players ready to import into your new league. Please note the 
Club-ID, Club Name, Team-ID and Team Name must match the data previously entered. If a 
player were to be representing Putney’s 12U and 14U Boys’ teams he would need to appear twice 
(once for each team) as can be seen in the example below with Oscar White on lines 2 and 7. 
 

 
 
It is also possible to export the players from the Competition Management System from the 
previous season’s league by logging onto the online league management area of the website. Click 
Admin → Export Player and team and using the XLSX link download/save the spreadsheet to 
your computer. 
 

 
 
You will need to copy and paste the data onto the Player import spreadsheet which can be found in 
the templates available on the League Planner page of the LTA website. You will need to add Club 
IDs, Club Names and Team IDs to each record. 
 
As with the above please note the Club-ID, Club Name, Team-ID and Team Name must match the 
data previously entered. If a player were to be representing Putney’s 12U and 14U Boys’ teams he 
would need to appear twice (once for each team) as can be seen in the example below with Oscar 
White showing on lines 2 and 7. 
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Importing Into your New League 

 

When importing your spreadsheets into your new League Planner file the following order must be 

followed: 

1. Clubs 

2. Teams 

3. Players (optional) 
 

 

Importing Clubs 

 

1. Select Players → Import Clubs 

 

 
 

2. Select the location of the Excel spreadsheet. Click Next. 
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3. The fields should match automatically, if they don’t please select the field from the drop 

down list. Click Next. 

 

 
 

4. A list of all the clubs that are being imported will be shown. Click Finish. 

 

 
 

5. League Planner will then ask you if you wish for the clubs to be imported. Click Yes. 
 

6. League Planner will then tell you the clubs have been imported. Click Close. 
 
 

Importing Teams 

 

1. Select Teams → Import Teams 
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2. Select the location of the Excel spreadsheet. Click Next. 

 

 
 

3. The fields should match automatically, if they don’t please select the field from the drop 

down list. Click Next. 

 

 
 

4. Select the teams you wish to import (probably all). Click Next. 

 

 
 

5. Ignore the events screen as you have already specified which events they wish to enter in 

your spreadsheet. Click Finish.  
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6. The system will ask you to confirm that you are happy to enter the teams without assigning 

them an event. Click Yes. 

 

7. League Planner will then tell you the teams have been imported. Click Close. 
 
 

Importing Players 

 
League Planner offers the facility to import from nominations forms however this is not essential 
and is not recommended for leagues using the LTA Player Database.  
 

1. Select Player → Import Players 

 

 
 

2. Select the location of the Excel spreadsheet. Click Next. 
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3. The fields should match automatically, if they don’t please select the field from the drop 

down list. Click Next. 

 

 
 

4. A list of the players being imported will be displayed. You will see a line for each team the 

player plays for at this stage of the process. Click Finish. 

 

 
 

5. The system will ask you to confirm that you are happy to enter the players into the 

database. Click Yes. 

 

6. League Planner will then tell you the players have been imported. You will expect to see 

players being added and others updated, this is due to where players are added twice to 

compete in 2 teams. Click Close. When you look back at the players tab you will see each 

player exists only once and the teams have been combined. 
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Entering League Data Manually 

 

Entering Clubs 

 

1. Select Player → Clubs 
 

2. Click New 
 

3. Enter the Club Name and Club ID (LTA registration number).  You do not need to enter a 

district. 
 

4. Click OK and repeat the process for all clubs in your league.   
 

Entering Teams 

 

1. Select Team → Add and the team Properties screen will appear 
 

2. In the top field enter the name of the team 
 

3. Select the club name from the drop down menu 
 

4. Select the event that the club has entered from the list in Events. If you have two events in 

an age group you will need to decide which one the team will be accepted into. 
 

IMPORTANT:   You must add a new team for each event for each club 

 

5. Select the Contact tab at the top of the window and complete the fields you require.   
 

TIP:  If you wish to use League Planner to send emails, you must complete the email box. 

 

6. Finally click OK.  
 
When you have entered all your teams, click ‘Roster’ on the left-hand side and then click on an 
event.  The teams you have entered should appear in a list. 
 

Entering Players 

 

1. Select Player → Add from the menu for the player properties screen to appear. 
 

2. Enter the following details to allow you to effectively validate the players: 

• Surname;  

• First Name;  

• Gender;  

• Date of Birth;   

• Member ID;  

• Club (use the drop down arrow) 
 

3. The player now needs to be attached to a team. Select the Team tab at the top of the 

window and then click Add. The ‘Select Team’ window will appear.  
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4. Select the relevant team name (these are the teams that you manually added or imported 

earlier).  
 

TIP:  If you have a long list of teams, start typing the name in the search box at the top of 

 the window. The search will find the team in the list.    

 

5. Finally click OK.  
 
The team will now be added to the player and dropped into their record. If the player subsequently 
plays for another team for the same club, you can add this team later. 
 
 

Player Validation 
 
By using the LTA Player Validation option you can download player information into your LP file 
from the LTA database. (the LP file needs to be published first to enable this functionality) 
  
You will be able to obtain ratings, rankings, emails, telephone numbers etc. In order to use this 
function you must have completed the ‘First name’; ‘Last name’; ‘Gender’ and ‘BTM number’ for 
each player. It’s essential to include this data if players’ results are to be recorded. 
 
To validate the players: 
 

1. Select League → Player Validation 
 
Every player will have a status by his/her name: 

 

• Those players with a green tick have been validated and the most up to date 

information, including rating and ranking, will show for these players.   
 

• Those with a red cross have not been validated; this is possibly because of an 

incorrectly spelt surname or BTM number. You can use the LTA Player Search on 

the LTA website to find the correct details. Once you have corrected any the errors, 

repeat the LTA Player Validation process.  If the changes you have made match the 

system, a green tick will appear by the player.   
 

• An exclamation mark indicates that there is more than one player who fits the data 

given. By double clicking on the name a ‘Select Player’ box appears, bringing up all 

the potential players.  Select the correct player from the list and click OK. A green 

tick should now appear by the player’s name. 
 

Once all players have a green tick click ‘Next’ (if a player does not have a green tick, and 
you have done all you can to correct the data, please contact the LTA Customer Support 
Team for further assistance.) 
 

 

2. Click Finish to update the LP file with the players’ information. 
 
  

https://www.lta.org.uk/about-us/contact-us/
https://www.lta.org.uk/about-us/contact-us/
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CREATING DIVISIONS 
 

League Planner will schedule rounds according to a standard format of home and away.   
 

TIP:  If you wish to balance home and away fixtures. Be sure to check that you have 

 enabled the Balance Home and Away option in the League Properties on the Draws 

 tab before creating any draws (see page 15 for more information). 

 

If your teams play each other both home and away then you should have selected the draw type 
‘Round Robin – Home and Away’. 
 

TIP:  A video is available to support league organisers in setting up draws in League 

 Planner. This video is available online at www.LTA.org.uk/LeaguePlanner. 

 

Creating a Division (Draw) 

 

Draws can be created and managed from the Roster in League Planner. To create a draw: 
 

1. Click Roster on the left hand side. 

 

 
 

2. Select an event from the list under Event. 
 

3. Click on the Add Draw button. 
 

 

 
 

4. The Draw Wizard window will open and a dropdown menu will offer all official draw types.  

Select the appropriate draw type and click Next. 

 

  

http://www.lta.org.uk/LeaguePlanner


 

 

30 

5. Draw formats available in League Planner include: 

• Compass Draw 

• Elimination 

• Round Robin 

• Round Robin – Home and Away 

• Round Robin with Playoffs 

• Qualifying Draw 

 

6. Complete the settings for your draw. In most cases you will only need to set the size of the 

draw which will depend on the number of entries. You can also select a 3rd/4th playoff or, if 

creating a qualifying draw, tick ‘Qualification’. Click Next. 

 

 
 

7. The next screen allows you to choose what you would like to be displayed on the draw 

sheet (we advise that you do not change any settings here).  Click Next. 
 

8. In the final screen check the details provided and click Finish.   
 

9. Draws can be amended at any time in the Roster tab by double clicking on the draw.   
 

TIP:  If your event consists of a number of round robin divisions without a playoff, you will 

 need to create a draw for each division. Remember to provide a unique name for 

each  division as you create them.  

 

 

Adding Teams Into a Draw Manually 

 

If you have more than one division you will need to enter teams manually having determined which 

division is appropriate.  
 

1. Click Draws on the left hand side 
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2. Select the event you are wishing to make the draw for and click on the draw tab you want to 

add teams to. 

 

 
 

3. Double click on the draw line where you want the team to be placed.  

 

 
 

4. The Select Entry window will open, select the correct team by clicking on the team once 

and then click OK.  
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TIP:  If you have a long list of teams, starting to type the name of the team in the box above 

 the list will cause the list to scroll down to the relevant point.  Only teams that you 

have  not entered into the event will appear in the entries list, provided you have set all the 

 draws at the same stage number. 

 

5. To remove a team from the draw, right click on the team name and select Delete Entry.  

This will put them back on the entry list. 

 

 
 

Adding Teams to a Division/Draw Automatically 

 
If you only have one division within an event (e.g. 12 & Under Boys Division 1) use the automatic 
draw making process.   
 
To make a draw automatically: 
 

1. Select Draw → Make Draw 
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2. Select the event and stage for which you wish to make the draw and click Next. 

 

 
 

3. Select the entries by selecting the teams you wish to add.  If all Teams are to be entered 

use the All button.  NB. You can also seed teams by double clicking on the team name and 

entering the seeding in the field provided. Click Next.  
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4. The draw wizard provides options to separate your teams by options such as club, city and 

county dependant on the size of your league. It is advisable to select ‘Optimal separation’ 

this will ensure the teams are separated as much as possible. 

 

 
 

5. Click Next and your draw will appear in the Result window. If you are happy with the draw, 

click Finish.  If you are not happy click Re-make until you are happy, then click Finish. 
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SCHEDULING A LEAGUE 
 
Scheduling is handled from within the draws. Provided you have selected Balance Home and 
Away Matches in Round Robin in the League Properties, league planner will schedule matches 
so that they have roughly equal home and away matches. Ticking Show Round Numbers in 
Round Robins will help identifying the rounds if you are scheduling per round. 
 

TIP:  A video is available to support league organisers in fixtures in their league in League 

 Planner. This video is available online at www.LTA.org.uk/LeaguePlanner. 

 

1. Click the Draw icon on the left hand side 

 

 
 

2. Select the event from the list under Event you wish to schedule. 
 

TIP:  If your league has a fixtures meeting and you are using  

 LTA.TournamentSoftware.com to publish and manage your league, schedule all 

 matches for the first date of the league and then have the team captains reschedule 

 matches after the meeting. 

 
 

Scheduling Per Round 

Scheduling by round will schedule all matches in the given round across all draws at the same 
draw stage. To schedule by round: 
  

1. Right click on a fixture in the round you wish to schedule and select Schedule Round.   

 

 
 
  

http://www.lta.org.uk/LeaguePlanner
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2. Click on the appropriate date and time for the match and click OK.   

 

 
 

3. If you only want to schedule on the date click the date cell and click OK.  
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4. To clear a round, right click on a fixture in a round and click Clear Round Schedule. 

 

 
 

TIP:  If the wrong team is allocated as the home team for a fixture you can change this by 

 right clicking on the fixture and removing the scheduling by clicking Clear Match. 

Right  click again on the match and select Swap Home-Away.  
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Scheduling Per Fixture 

 
To schedule an individual fixture: 
 

1. Right click in the fixture and click Schedule. 

 

 
 

2. Click on the appropriate time and date for the match then click OK.   
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3. If you only want to schedule on the date click the date cell and click OK. 

 

 
 
 

TIP:  By ticking Force Planning a match can be scheduled without taking team or court 

 availability into account. 

 

4. To clear a fixture, right click on the fixture and click Clear Match. 
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Using Fixture Templates (scheduling on your terms) 

 
Using a Fixture Template allows you to set the pattern of your league’s fixtures i.e. the matches 
you want in each round.  If you do not use a Fixture Template, League Planner will schedule your 
league fixtures randomly.  
 

1. You first need to create a new fixture template.  Select Draw → Fixtures 

 

 
 

2. The Fixtures window will appear. You will start by creating a New Fixture Template.  Click 

on the Add Fixture Template button. 

 

 
 

3. Enter the name of your new fixture template e.g. 

Summer League, enter draw size of your divisions. 

You can use the same fixture template for multiple 

divisions as long as they are the same size (have the 

same number of teams). The Stages field signifies 

the number of times the teams will play each other. 

For example if teams play each home and away you 

should insert 2 in the field. 
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4. Click on the Matches tab and enter the order in which you want the teams to play each 

other in.  In this example we have 7 teams and we can choose the order in which we want 

the fixtures to take place.  For example, we may want team 1 to play home in round 1 and 

round 4 so we will set up our fixture template to actuate this. 

 

 
 

5. Once you have entered your required pattern in the Matches tab click Validate to check if 

you have made any errors. If no errors are found click OK and your new fixture template 

will be saved. 
 

TIP:  Fixture templates can be used more than once with different dates assigned to each 

 round. 

 

6. You will now add the dates for the current year’s fixtures by clicking on Add Fixture. 
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7. Enter the name of your set of fixtures e.g. Men’s Summer League and select the template 

i.e. Summer League that you want to apply the dates to. Double click on each of the round 

numbers and enter the date that each round will be played on in the format dd/mm/yyyy. 

You can also enter the time, if required, in the format hh:mm. 

 

 
  

8. Finally, select the Draw tab of the Fixtures window. You now need to apply the relevant 

fixture template to the appropriate draws. 
 

9. Highlight the draw (division) by selecting it. 

 

10. Select the appropriate fixture and click the arrows button to apply. 

 
 

 
 

 

11. Repeat this process for all draws and, once you have applied your fixtures to all the draws 

(divisions), click Execute 

 

12. You should go back to the Draws section of League Planner and check each draw 

(division) has the appropriate dates assigned. 
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League Planner’s Scheduling Algorithm 

 
If you chose not to create your own fixtures template to determine who will play each other in each 
round. We thought you may wish to know which matches League Planner will group in each round.  
 
3 Teams 
Round 1: 2 v 3 
Round 2: 1 v 2 
Round 3: 3 v 1 
 
4 Teams 
Round 1: 2 v 3, 1 v 4 
Round 2: 1 v 2, 4 v 3 
Round 3: 3 v 1, 2 v 4 
 
5 Teams 
Round 1: 3 v 4, 2 v 5 
Round 2: 1 v 2, 5 v 3 
Round 3: 3 v 1, 4 v 5 
Round 4: 2 v 3, 1 v 4 
Round 5: 4 v 2, 5 v 1 
 
6 Teams 
Round 1: 3 v 4, 2 v 5, 1 v 6 
Round 2: 1 v 2, 5 v 3, 6 v 4 
Round 3: 3 v 1, 4 v 5, 2 v 6 
Round 4: 2 v 3, 1 v 4, 4 v 5 
Round 5: 4 v 2, 5 v 1, 3 v 6 
 
7 Teams 
Round 1: 4 v 5, 3 v 6, 2 v 7 
Round 2: 1 v 2, 6 v 4, 7 v 3 
Round 3: 3 v 1, 5 v 6, 4 v 7 
Round 4: 2 v 3, 1 v 4, 7 v 5 
Round 5: 4 v 2, 5 v 1, 6 v 7 
Round 6: 3 v 4, 2 v 5, 1 v 6 
Round 7: 5 v 3, 6 v 2, 7 v 1 
 
8 Teams 
Round 1: 4 v 5, 3 v 6, 2 v 7, 1 v 8 
Round 2: 1 v 2, 6 v 4, 7 v 3, 8 v 5 
Round 3: 3 v 1, 5 v 6, 4 v 7, 2 v 8 
Round 4: 2 v 3, 1 v 4, 7 v 5, 8 v 6 
Round 5: 4 v 2, 5 v 1, 6 v 7, 3 v 8 
Round 6: 3 v 4, 2 v 5, 1 v 6, 8 v 7 
Round 7: 5 v 3, 6 v 2, 7 v 1, 4 v 8 
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ENTERING RESULTS 
 
When entering a match result the rubber results and match result need to be entered. 
 
 

Entering Players per Fixture 

 

1. Click on the Matches’ icon on the left hand side. This will bring up all your fixtures. 

 

 
 

2. If you have scheduled all the fixtures a list will appear. If you have any unscheduled 

fixtures, you can still enter results for these; click the Unscheduled tab at the bottom of the 

screen. 

 

 
 

3. Click once on a fixture for the rubbers window to appear in the second applet. 
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4. Double click on the first rubber and the scoring box will appear. Select the appropriate 

player from each team’s drop down menu under the club name.  

 

 
 

5. For early fixtures players names may not appear because the players have not yet been 

assigned to a team or added to the league. To add or assign players to a team refer to 

Importing Players and Entering Players Manually section or click the browse button .  
 

6. Select players from the Club tab to add them to the team. If the player does not appear in 

the list click New to manually add them. 
 
 
  



 

 

46 

Entering Rubber Results (Player v Player): 

Once you have identified the players competing in the rubber you are now ready to enter the score. 

 

1. Enter the score by typing the number of games the loser won in their row.  Do this for each 

set played.  
 

TIP:  LP automatically enters the winning set score based on the information you provided 

 in the Draws tab of the League Properties.  This means you only need to enter the 

 losing player’s set score. If you want to switch this function off un-tick the Auto 

 complete box in the Draws tab of the Properties section.  

 
2. Once the score is entered click OK and move on to the next rubber. Repeat the process 

until all the individual results have been entered.  
 

 
 
 

TIP:  If you have selected to use a format with a deciding match tie-break to be formatted 

as  (Match Tie-Break - record as [1-0]). The score should be entered as 1-0 with the 

 zero in the losing player’s row. The loser’s score in the tie-break should be entered in 

 the Tie-break cell E.g. if 10-5, 5 should be entered in the tie-break cell for the third set. 

 If a normal set goes to a tie-break you should enter 6 in the losing player’s row and 

the  losing player’s tie-break score in the Tie-break row.   
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Entering Fixture (Team v Team) Results: 

When you have completed the rubber results you now need to check that the team result has been 
calculated correctly. 
 

1. Double click on the match fixture in the top applet of the screen to open the Team Match 

window. Click Calculate to populate the result based on the rubber results you entered 

earlier then click OK.  NB. Once the result is calculated it will move into the finished tab 

(see bottom of screen). 

 

 
 

3. If the outcome of the calculation is not as it should be go back and check that you have 

recorded the results correctly by cross referencing with the match card/s.  
 

4. If you need to adjust the team v team match score, e.g. the players have not played in the 

right order, you need to adjust the score using the points fields next to the team name. The 

sets and games score will be calculated automatically.   
 

5. You can make any match notes by clicking on the Note tab.  
 

6. If Penalty Points apply to your league use the ‘Penalty Pts’ tab to apply these as required. 
 

7. Once you are happy that the result is complete and accurate click OK to finish.   
 
 

TIP:  Have you considered running your league online? With online leagues 

 Team captains can enter results themselves and the leagues tables are automatically 

 updated.   This spreads the workload and saves you a lot of time. For more 

 information visit www.LTA.org.uk/LeaguePlanner/. 

 
  

http://www.lta.org.uk/LeaguePlanner/


 

 

48 

PUBLISHING A LEAGUE 
 

Publishing your league allows teams and players to view league tables, fixtures and results online. 
 
When your league is ready to be displayed online select Internet → Publish. 
 

 
 
You can attach your league rules by clicking on the Regulations tab. Click Load Text and then 
proceed to locate your league rules.   
 

 
 
Click on the publish button and your league will be published to competitions.lta.org.uk. When all 
items at the bottom of the screen have green ticks, click close. 
 
If you are running a league in your LP file, i.e. adding results directly to this file rather than to the 

online league, you should publish on a regular basis so that players can see their most up to date 

results. 

 
  

https://competitions.lta.org.uk/
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If publishing an online league where team captains enter results online; you must publish your 

league as above and then fill the League Conversion Application Form to request the league to be 

converted. 

 

REPORTING  
 
The reporting section is located in the top menu bar Report. Here you can find and export 
information on: 

• Matches;  

• Draws (Divisions);  

• Entries;  

• Teams;  

• Players;  

• Overview league stats 
 
This section includes reports that are useful before and during the season and reports that 
summarize activity in post season. 
 
 
  

https://www.lta.org.uk/workforce-venues/officiate-tennis/competition-organiser-resources/lp/league-planner-conversion-form/
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SAVING FILES 
 

Saving your File  

 
When you first install League Planner, a folder within My Documents is created as part of the 
installation process. The folder is called Tournaments.   
 
You can specify where you want to save the file in the league creation stage which will usually be 
the Tournaments Folder in My Documents. Updates to your league are automatically saved; when  
exiting all you need to do is close League Planner.  Either select close from the league menu or 
simply close League Planner entirely.   
 
 

Backing up Files 

 
It is good practice to back up your League Planner file and store on an external device such as a 
memory stick. Creating a backup is also the way to email your League Planner file.  
 
To create a backup: 

1. Click League → Backup  

2. Select where you want the backup file to be saved to by clicking on the Browse button. 

The default location is set to ‘Tournament’ folder as described above.  

3. Click Finish.  

4. You can now email the backup file. 
 
 

Restoring a Backup File 

 
To open a backup file you must restore it.  
 
To do this: 

1. Select League → Restore 

2. Click the Browse button to find the location of the file.  

3. Click Open.  

4. Select the location of where you wish to restore your file to and click Finish to load the 

backup file – this may take a couple of minutes. 
 
  



 

 

51 

BUTTONS IN LEAGUE PLANNER 
 

 
New Tournament 

 

 
Delete Note 

 
Open Tournament 

 

 
Schedule Match 

 
Backup Tournament 

 

 
Schedule Round 

 
Restore Tournament 

 

 
Clear Match 

 
Tournament Properties 

 

 
Match Properties 

 
Find Team 

 

 
Show Match 

 
Matches of Team 

 

 
Select Entry 

 
Matches of player 

 

 
Delete Entry 

 
Add Team 

 

 
Make Draws 

 
Delete Team 

 

  

 
Add Player 

 

 
Match to Court 

 
Delete Player 

 

 
Free Court 

 
Matches of player 

 

 
Show Draw 

 Entry Properties 

 

 
Add Player Match 

 
Add Draw 

 

 
Delete Player Match 

 
Delete Draw 

 

 
Auto Teammatch Score 

 
Add Note 

 

  

 


